Nylas V3 Scheduler in WeWeb

I’m attempting to add the Scheduler UI components to our WeWeb app (vue.js)

I’ve been able to import the UI components for both the editor and the scheduler successfully.

My Issue / Challenge:
After authenticating with Google or Microsoft, when returned back to the callback URI with the “code” for token exchange I’m getting error code: 45004, Code Verifier Challenge Failed.

I believe because the Grant ID is never verified, the UI for the scheduler editor never changes from the “click to login state” so I’m unable to move further in the scheduling pages setup, etc.

I’m not sure how to resolve this issue, and have been trying to understand the documentation to troubleshoot on my own. But, I’m stuck.

Hi @matt.tidwell - thanks for posting, we do have a Scheduler Quickstart guides with working code, have you tried following the steps there (we include working code repos too!)?

I am wondering if the issue you are facing is WeWeb or Nylas specific :thinking:

Hi Ram, I’ve been working through all of the steps in the Quickstart. It seems to be related to the Callback URI workflow.

It doesn’t seem to be WeWeb specific. There are several other threads here in the comments with various tools that all seem to have this issue at one point. For me, it seems that my handoff from “Code” to “Token” isn’t working - all the backend logs on Xano are where we are receiving the error.

So it makes me think it’s not WeWeb-related yet, but the UI in WeWeb isn’t updating because the Token is never received.

1 Like

@matt.tidwell thanks for responding and sharing more details. I recommend to revisit the Register callback URI section and report back.

I’m going to block off some time to load the scheduler react repository locally and see if I experience similar.

Also - another way to quickly check that everything is working with your authentication configuration, via hosted authenication, is by clicking on GrantsAdd a test grant:

@matt.tidwell - I was not able to reproduce the issue using the Quickstart guide repository and the Nylas Sandbox account.

Follow up questions, are you using your a different Google and Microsoft connectors, or the Nylas Sandbox account (no connectors required, and for testing purposes)?

Hi @ram thanks so much for these notes. I am using the Google connectors. I’m also currently in the Nylas Sandbox as well.

Here’s a quick video showing the behavior and the errors I’m seeing once we receive the code back on the callback URL. Apologies if I’m missing something really obvious here. Thanks so much for your responses.

Hi @matt.tidwell let me check with the team on this.

I cannot reproduce using the Github repository as is, have you tried pulling the repo and running it? This will help us debug further :+1:

Also @matt.tidwell are you able to share the network requests details between the redirect and your application.

I suspect this call is failing:


Can you also share what is being sent over, it should be something like this:

    "client_id": "CLIENT_ID",
    "redirect_uri": "REDIRECT_URI",
    "code": "CODE",
    "grant_type": "authorization_code",
    "code_verifier": "CODE_VERIFIER"

Also, can you share the scheduler config you are using? :slightly_smiling_face:

Ah, just to close the loop - the solution is callback URI was set to web it had to be javascript.