Google Meet Not Available in Scheduler Editor UI

I have used the quickstart guide project to implement the Scheduler, but having issues adding Google Meet as the conference provider. Here’s my code:

              conferenceProviders = {{"google": "<GRANT ID>"}}
                clientId: "<CLIENT ID>", // Replace with your Nylas client ID from the previous
                redirectUri: `${window.location.origin}/scheduler-editor`,
                domain: "", // or '' for EU data center
                hosted: true,
                accessType: 'offline',
                  selectedConfiguration: {
                    requires_session_auth: false, // creates public configuration which does not require session tokens
                    scheduler: { // callback URLs to be set in email confirmation messages

Hi @alienator we’ll look into this and let you know as soon as possible.



Thank you Blag. I found another issue. After I provide my name and email as a participant/customer to set the meeting using the Scheduler, there is no invite or email sent to me as a participant/customer. I only see the meeting on the organizer’s calendar.

@alienator to answer your first question

You need to update the UI component to the latest

npm install @nylas/react@latest

That should update the UI to include Google Meet. Just a note, there’s a bug open right now where Meet doesn’t show up as a provider when you create a new page, but if you go back in to update the page it will be there. The scheduler team is aware of this and it will be fixed, so please bear with us.

Let me know if that fix things for you :smiley:

@alienator For your second question can you provide us a link to your booking page so we can take a look? :slight_smile:

Hey @Blag, thank you so much for getting back to me.

For the first issue, the Meet option does show on the second page after the calendar is created as you mentioned.

For the second question, it started working fine. Maybe I had some wrong settings, but I am not facing that issue anymore.

Thank you.

@alienator Glad things are working fine :star_struck: Let us know if you need anything else :wink: